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Getting started
How does the SMART Board™ 
interact ive whiteboard work?

The SMART Board™ interactive whiteboard is very easy to use. If you can use a computer, you can 
use an interactive whiteboard.

The touch-sensitive display connects to your computer and projector to show your computer image. 
You can control applications from the display with your finger, write notes in digital ink and save 
your work to share later.
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How does the SMART Board interactive whiteboard 
work?
The SMART Board interactive whiteboard is touch sensitive and operates as part of a system that 
includes a computer and a projector. 

 

•  The computer sends an image of an application to the projector

•  The projector casts the image onto the interactive whiteboard

•  The interactive whiteboard acts as both the monitor and input device, allowing you to control an 
application by simply touching the interactive whiteboard

It may help you to think of your interactive whiteboard the same way you think of your mouse or 
keyboard – it is an input device that enables you to control applications on your computer. 
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Safety tips
•  You and your students should never look directly at the light beam from the projector. You (and 

your students) should always take a step (or even two) sideways before turning to face the 
class.

•  Tell your students not to touch the projector, as it can become extremely hot during normal 
operation

•  Don’t use a chair to increase a student’s reach. If your students can’t reach the top of the 
interactive whiteboard, lower it. You may need to remount a wall-mounted unit to a lower 
position. If your interactive whiteboard is mounted on a floor stand, lower it with the help of 
another adult.

•  Tell students not to run in the vicinity of the floor stand, as they may trip over the floor stand’s feet
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Your finger is your mouse
You can control applications on your computer from the interactive 
whiteboard. A press with your finger on a SMART Board interactive 
whiteboard is the same as a click with your mouse. You open an application 
the same way you do on your desktop computer, but instead of using your 
mouse to select and open files, just press or double-press the application icon 
with your finger. 

Orienting the interactive whiteboard will ensure the cursor is aligned with your finger press. 

The SMART Pen Tray
The SMART Pen Tray consists of four color-coded slots for pen tools and one slot for the eraser. 
Each slot has an optical sensor to identify when the pen tools and eraser have been picked up. You 
can write with the pen tool or with your finger, as long as a pen slot is empty. The technology in the 
pen tray is smart enough to know which tool was removed from its slot most recently. If you remove 
the eraser from its slot while you are still holding a pen tool, the pen tray will assume you want to 
erase. The lights above the tool slots indicate which tool was removed last. 

The pen-tray buttons
The pen tray has at least two pen-tray buttons. One button is used to launch the On-Screen 
Keyboard. The second button is used to make your next touch on the interactive whiteboard a right-
click. Some interactive whiteboards have a third button. The third button is used to access the Help 
Center quickly. 

Pen-tray buttons
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The pen tools
The SMART Board interactive whiteboard comes with four pen tools, which are black, red, green 
and blue, and one eraser. Although you do not need to use the pen tools to write on your interactive 
whiteboard, they do make writing more intuitive. Pick up a pen tool from the SMART Pen Tray and 
begin writing. To erase your digital ink, remove the eraser from the pen tray and move it in a smooth 
motion over your notes. The notes will disappear.

The On-Screen Keyboard
This on-screen, virtual keyboard eliminates the need for an attached physical keyboard, as you can 
use its many views to enter typed text. There are several available keyboard views, including the 
Classic, Write, Simple, Simple Capitals, Number Pad and Shortcut view.

To open the keyboard, press the SMART Board icon in the notification area and select Keyboard. 
Alternatively, press the Keyboard button on your SMART Board interactive whiteboard pen tray. 

Type or edit text in any application without leaving the interactive 
whiteboard.

Press the Keyboard button on the pen tray to launch the On-Screen 
Keyboard.

Classic view
Press the virtual keys to type text, then press the Send button to place the text into the active dialog 
box or application. You can type into any application, whether it’s Ink Aware or not. 

Select a
view
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Preview pane 
Press the double-arrow button to open the preview pane. When the preview pane is open, you can 
type an entire word or sentence before sending any information to an application. When you are 
finished typing, pressing the Send button will send your text to the active application.

Simple views
Teachers who are teaching students who are just learning the alphabet, or who are not yet familiar 
with a standard keyboard layout, will appreciate the two simple views available – Simple and Simple 
Caps. In both of these views, the letters are arranged in alphabetical order, followed by digits 0 
through 9. 

Double arrow buttonPreview pane
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The right mouse button
Press the right mouse button on the pen tray to have your next press 
on the screen recognized as a right-click. 

A graphic in the bottom right of your screen will appear to remind you 
that your next press will be registered as a right-click. 

Orienting your SMART Board interactive 
whiteboard
Orientation ensures your touch is 
registered accurately when you are 
using the interactive whiteboard. 

If you are touching an icon and your 
cursor appears somewhere other 
than where you are pressing, try 
orienting the interactive whiteboard. 
After orientation, your cursor should 
appear wherever you are touching the 
interactive whiteboard.

To launch the Orient function, press 
and hold the keyboard button and the 
right mouse button simultaneously 
until the Orientation screen appears.

TIP: Instead of pressing the right mouse button, press and hold on the area of the screen where 
you would like to make a right-click. After a few seconds of pressing and holding the area, the 
right-click menu will appear.

The Orientation screen
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The Help button
If the pen tray features a help button, press it to launch the Help 
and Support for Your SMART Board Interactive Whiteboard dialog 
box. The dialog box provides one-touch access to information that 
will help you answer almost any question relating to your SMART 
product. 
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The Ready Light 
Your SMART Board interactive whiteboard includes a Ready Light that indicates the status of your 
interactive whiteboard. 

Color of Ready Light Status

Not lit •  The interactive whiteboard does not have power

•  Check the USB cable connections

Solid green •  The interactive whiteboard is successfully communicating with the 
SMART Board software on the computer

Flashing green •  The SMART Board driver isn’t installed. Or if it’s installed, it isn’t 
running. Verify that the driver is installed, and if it isn’t, install it. 

•  If the Ready Light continues to flash green, you may want to contact 
your support representative for assistance

Solid red •  The interactive whiteboard has power, but it is not communicating 
with the computer

•  During the initial powering up or power reset, you will see the Ready 
Light turn red for a moment

•  This brief red illumination is normal

Flashing amber •  Occurs only when you are updating firmware using SMART’s 
Firmware Flashing Wizard

•  This is normal

Solid amber •  Problem state

•  Try resetting the interactive whiteboard by disconnecting and then 
reconnecting the USB cable at the interactive whiteboard end
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Writing notes
Make notes or drawings by removing a pen tool from the pen tray and writing on the surface of the 
interactive whiteboard.

The Digital Ink Layer
When you remove a pen tool from the pen tray, a border appears around your desktop, 
and the Floating Tools toolbar launches. If it does not launch immediately, press the 
SMART Board™ icon located in the Windows Notification Area at the bottom right of 
your screen. Choose Show Floating Tools... from the menu.

The border indicates the Digital Ink Layer is in place, and you can write on the desktop just as you 
would write on a transparent sheet. The Digital Ink Layer and its visible border remain in place until 
all pen tools and the eraser have been returned to the pen tray and you touch the board.  

Close 
Digital Ink 
Layer

Capture 
writing

Clear 
writingBorder

Floating 
Tools toolbar
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Your first touch on the board, after returning all the pen tray tools, will 
bring up a menu with options for capturing your writing. If you wish to 
hide this menu in the future, click Ink Layer Options... and select the 
Close ink layer with pointer checkbox. 

To save an image of the screen on which you were writing into a new 
Notebook page, choose Save Ink. To clear the writing but keep the 
Digital Ink Layer in place, choose Clear Ink. To remove the Digital Ink 
Layer and clear the writing, choose Close Ink Layer.

Restoring your notes and drawings
If you accidentally clear your ink, you can restore your notes and drawings by 
pressing the Click here to restore ink icon, located in the lower right of the 
screen. You can then use the Capture writing button to save your notes.

If you do not see the Click here to restore ink message or don’t reach it before 
it disappears, press the Undo button in the Floating Tools toolbar to restore 
your notes and drawings. Undo 

button
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Advanced feature – Capturing your notes and drawings
If you wish to capture a specific area of your screen, press the SMART Board icon located in the 
Windows Notification Area at the bottom right of your screen. Choose Other SMART Tools > 
Screen Capture Toolbar... from the menu to launch the Screen Capture Toolbar.

To capture an area of your desktop, follow these steps:

  1  Press the Area Capture button on the 
Floating Tools toolbar. The Area Capture 
tool will appear.

  2  Press on any corner of the area you wish 
to capture and, continuing to press, drag 
the selection box until it surrounds the 
entire area

  3  Release your press and your selection will be captured as a graphic into Notebook software. 
If Notebook software is not already open, it will open automatically when you capture a 
portion of your screen. Save your Notebook file by selecting File > Save.

Area Capture 
button

Window
Capture 
button

Screen 
Capture 
button

Freehand 
Capture 
button
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Review questions: Getting started
  1  Name the three components required to operate a SMART Board interactive whiteboard.

  2   How do you know when the interactive whiteboard is ready to be used?

  3  Circle the pen-tray button that launches the On-Screen Keyboard. 

  4  Describe one way to begin the orientation process.

  5  How do you right-click on the interactive whiteboard?

  6  Name two ways to restore writing that was cleared when you closed the Digital Ink Layer.
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Review answers: Getting started
  1  Name the three components required to operate a SMART Board interactive whiteboard.

Interactive whiteboard
Computer
Projector

  2   How do you know when the interactive whiteboard is ready to be used?

The Ready Light is a steady green. 

  3  Circle the pen-tray button that launches the On-Screen Keyboard. 

  4  Describe one way to begin the orientation process.

Press and hold the keyboard button and the right-mouse button on the pen tray 
simultaneously.

  5  How do you right-click on the interactive whiteboard?

Press the right mouse button on the pen tray to have your next press on the interactive 
whiteboard recognized as a right-click. 

  6  Name two ways to restore writing that was cleared when you closed the Digital Ink Layer.

Press the Undo button on the Floating Tools toolbar.
Press the Click here to restore ink icon in the lower right of the screen.
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Hands-on practice: Basic functionality
Your school or company has just moved one of your SMART Board interactive whiteboards into a 
new room because you were unable to access the Internet from the old location. You will be the first 
person to use it in the new environment and will be showing everyone how to use it and the Internet 
together.

You have learned through experience that whenever a piece of technology gets moved, it’s a good 
idea to test it before you deliver a lesson or presentation. The computer, interactive whiteboard and 
projector appear to be working properly when you turn everything on. However, when you double-
press the Internet browser icon on your desktop, your cursor appears a few inches away from your 
finger press.
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Orienting your SMART Board interactive whiteboard
You remember that when the projector or interactive whiteboard moves location, you should orient 
the board. This action will tell the computer where the image of the desktop is being displayed on 
the surface of the interactive whiteboard.

  1  To orient the interactive whiteboard, press and hold the keyboard button and the right 
mouse button simultaneously until the Orientation screen appears

  2  Begin the orientation process at the upper-left corner of the Orientation screen. Press your 
finger or pen tool firmly on the center of each cross in the order indicated by the white, 
diamond-shaped graphic.

NOTE: The point is registered when you remove your finger, not when you first touch the       
Orientation screen.

Pen-tray buttons

The Orientation screen
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Testing basic functionality
It’s a good idea to test the basic functionality of your interactive whiteboard to ensure all the appli-
cations you will be using to deliver your lesson or presentation are working properly.

1  Using your finger, double-press on the Internet browser icon (e.g., Internet Explorer®) to 
launch the Internet

2  Press the On-Screen Keyboard button on the SMART Pen Tray

3  Press once inside your Internet browser’s address bar to select the website address 

4  Using the On-Screen Keyboard, type www.google.com

NOTE: The On-Screen Keyboard is a single point of contact. Touch-typing or keystroke 
combinations are not possible.
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5  Press the Go button beside your Internet browser’s address bar

6  Pick up a pen tool from the pen tray. The Digital Ink Layer will appear, as shown by a visible 
border around the desktop. The border indicates you can write on the desktop, and it 
remains in place until you close it or navigate to a different application.

7  Using a pen tool, circle the browser’s Back button
8  Return the pen tool to the pen tray, and touch the interactive whiteboard once. Choose 

Clear ink from the menu to erase your ink. Press the Click here to restore ink icon at the 
bottom right of the screen to bring the circle back.

You have now confirmed that you can clear your notes by touching the interactive 
whiteboard, then restore your notes by pressing the Clear here to restore ink icon.

9  To ensure you will be able to capture and save important information for a future lesson or 
presentation, launch the Screen Capture toolbar by pressing the SMART Board icon located 
in the Windows Notification Area at the bottom right of your screen. Choose Other SMART 
Tools... > Screen Capture Toolbar... from the menu.

  10  Press the Area Capture button.

Digital Ink Layer
border

Area Capture 
button
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11  Press the interactive whiteboard and, without releasing pressure, drag the selection box 
using your finger to outline the circle around your browser’s Back button. Release your press 
to capture the image to Notebook software. 

NOTE: SMART Notebook software will open automatically, and your notes and background 
will be saved to a new SMART Notebook page.

12  Clear the circle from your browser’s Back button
13  Select the unsaved Notebook file from the taskbar to view your captured image in Notebook 

software. Select File > Save to save your notes for future reference.
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Working with 
Ink Aware 
applications
What is Ink Aware?

When software is Ink Aware, you can write and draw directly into the active file. For example, if you 
write a note or draw something while using Microsoft® Word software, you can save your Word file 
and your notes will be visible the next time you open it.
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How do Ink Aware applications work? 
Ink Aware applications recognize which area of the software is the active work area and which area 
is used for buttons and toolbars. When you use a pen tool to draw or write over the active work area 
of an Ink Aware application, you can convert it to a format that the application recognizes. Once the 
ink is in a recognized format, you can use that application as you normally would.

Which applications are Ink Aware? 

This section will focus on the most commonly used applications – Microsoft Word, Excel and 
PowerPoint.

Microsoft 
Office

Microsoft Word, Microsoft Excel®, OpenOffice Calc, OpenOffice Writer

Graphic 
applications

CorelDRAW®, OpenOffice DRAW, Microsoft Imaging, Corel® Grafigo™ 2, 
Microsoft Paint®, ArcView, Autodesk® DWF Composer 2.0, Volo® View 
Express

Presentation 
applications

Microsoft PowerPoint®, Corel Presentations™, Microsoft Office Live Meeting, 
Microsoft NetMeeting® 2.0/2.1/3, OpenOffice Impress 

Other 
applications

AutoCAD®, AutoVue™ Professional, Microsoft Windows® Journal, Microsoft 
Office OneNote®, Microsoft Visio®, Adobe® Acrobat® Professional 6.0/7.0/8.0 

Buttons and 
toolbars area

Active work area

}
}
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Microsoft Word and Excel software
When using Word or Excel software with your SMART Board™ interactive whiteboard, you will 
notice four buttons. They may be integrated with the application toolbar or separated as a floating 
toolbar.

If you do not see this toolbar, pick up a pen tool from the pen tray (Microsoft Office 2007) or select 
View > Toolbars > SMART Aware Toolbar (Microsoft Office 2003).

Adjust settings to 
automatically insert the 
drawing as an image

Insert drawings or 
writing as an image 
directly into document

Convert writing as typed text 
directly into document. Text will 
appear at the cursor point in the 
pen color used.

Save a screen capture in 
SMART Notebook software
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Word example: Pressing the Insert as Image button

Before you press the button, your ink is not part 
of the Microsoft Word document. Pressing on 
the page clears the ink.

Press the button and your ink is recognized as 
an image within the Microsoft Word document.

Excel example: Pressing the Insert as Text button

Before you press the button, your ink is not part 
of the Microsoft Excel software file. Pressing 
on the page clears the ink.

Press the button and the text becomes part of 
the Excel software file.
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Microsoft PowerPoint software
When you work with PowerPoint software in Normal view on an interactive whiteboard, you can 
save your hand-written notes as images or text and save screen captures to SMART Notebook 
software, just as you can when using Microsoft Word or Excel software. Ink Aware features can be 
accessed through the SMART Aware Toolbar. Note that you will only see this toolbar when you are 
in Normal view.

When you present with PowerPoint software on an interactive whiteboard, you can also save your 
notes as images and save screen captures to SMART Notebook software. Ink Aware applications 
can be accessed through the Slide Show toolbar, which launches when you enter Slide Show view. 
Note that you will only see this toolbar when you are in Slide Show view. 

TIP: You can go to the next slide of a PowerPoint software presentation by pressing twice on the 
interactive whiteboard, making the second press to the right of the first. To go to the previous 
slide, make the second press to the left of the first. 

Adjust settings to 
automatically insert the 
drawing as an image

Insert drawings or 
writing as an image 
directly into the slide.

Convert writing as typed text 
directly into the PowerPoint slide. 
Text will appear at the cursor point 
in the pen color used.

Save a screen 
capture in Notebook 
software

     Slide Show toolbar

Go to the next 
slide in your 
presentation

Open the Command menuGo to the previous
slide in your
presentation
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The Command menu
Press the center button on the Slide Show toolbar to launch the Command menu.

PowerPoint Commands submenu

TIP: Use the Black/Unblack Screen command when you would like to draw the attention of your 
class or audience away from the screen and to the presenter. Press twice in rapid succession 
anywhere on the screen to resume your slide show exactly where you left off. 

Capture an image of the current 
slide to SMART Notebook software

Save your notes directl
into your PowerPoint    
presentation file

Delete your notes from the page
Add an additional slide 
presentation

Launch the PowerPoint Commands 
submenu

Launch the Settings 

Launch the Floating Tools toolbar 

End the slide show 

Skip to any slide in your presentation

Make the screen black

Print the slide on your default printer 

Open the PowerPoint software menu
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Settings submenu

Deselect to advance slides 
with a single press

Deselect for an opaque toolbar
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SMART Floating Tools toolbar
The Windows Operating System taskbar and notification area are hidden when you are presenting 
a PowerPoint software slide show. You can still launch the Floating Tools toolbar by selecting 
SMART Floating Tools from the Command menu. 

TIPS:

  1  Use the Ink Aware toolbar buttons to convert your notes directly in Microsoft Word and 
Excel software

  2  The Slide Show toolbar in PowerPoint software allows you to control a PowerPoint 
software presentation while you are at your SMART Board interactive whiteboard 

  3  You can launch the Floating Tools toolbar during a PowerPoint software slide show by 
selecting Slide Show Toolbar > Command Menu > SMART Floating Tools
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Review questions: Ink Aware
  1  Describe the function of each of the buttons on the Ink Aware toolbar that appears in 

Microsoft Word software.

  2  Describe how to insert digital ink as text into a selected cell of an Excel software 
spreadsheet.

  3  Describe how to save writing on a PowerPoint slide into SMART Notebook software when 
in Slide Show view. 

  4  Describe how you would save your notes and drawings to PowerPoint software files.
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Review answers: Ink Aware 
  1  Describe the function of each of the buttons on the Ink Aware toolbar that appears in 

Microsoft Word software.

•  Insert as Image: Inserts notes as an image into the document or spreadsheet
•  Insert as Text: Converts notes into typed text and inserts them into the document or 

spreadsheet
•  Capture to SMART Notebook: Captures the visible active work area into SMART 

Notebook software
•  Settings allows drawings to be automatically inserted into the document as an image

  2  Describe how to insert digital ink as text into a selected cell of an Excel software 
spreadsheet.

To save digital ink as text, press the Insert as Text button on the Ink Aware toolbar 

  3  Describe how to save writing on a PowerPoint slide into SMART Notebook software.

Press the center button on the three-button Slide Show toolbar and select Capture to 
Notebook. Both the slide and the notes will be captured as an image to SMART Notebook 
software. 

  4  Describe how you would save your notes and drawings to PowerPoint software files.

Press the center button on the three-button Slide Show toolbar and select 
Insert Drawing as Image. 

If you do not save your notes and move forward to the next slide, you will be prompted to 
save your notes when you end the slide show. This option can be deselected in the 
Settings submenu. 
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Hands-on practice: 
Ink Aware and Microsoft Word software in the 
classroom

Before you start
Before you begin your class, ensure that your computer is turned on and the SMART Board 
interactive whiteboard is connected and oriented. 

This hands-on practice assumes you have a basic understanding of the Microsoft Windows 
operating system.

Preparation
Create a short, two-question quiz. In a real-world example, you would open a quiz prepared in 
advance.

  1  Open a blank document in Word

  2  Type a mathematical equation using your computer’s keyboard – for example, 13 x 7 =. Press 
the Enter key several times to give your students space to show their work.

  3  Type Complete the following sentence with either “quick” or “quickly.” Press the Enter key 
twice, then type When excited, she spoke very
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Using Ink Aware in the classroom
Your class has just completed the quiz you created in Word. Now you would like to review the 
answers as a group.

  1  Use a pen tool from the SMART Pen Tray to demonstrate how to arrive at the correct answer 
on the interactive whiteboard. Put the pen tool back in the pen tray, and press the Insert as 
Image button to add the answer to your Word file.

  2  Move to the next quiz question. Discuss with your class when to use the word quick versus 
quickly in the sentence.
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  3  Touch the interactive whiteboard to place the cursor at the end of the sentence

  4  Use a pen tool from the pen tray to write the correct answer on the interactive whiteboard
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  5  Press the Insert as Text button to convert the correct answer to text. The text will appear at 
the cursor point in the pen color used.

  6  Save your document in Word. Now you can e-mail or print copies and distribute the answers 
to your students. 
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Hands-on practice: Ink Aware and Microsoft Excel 
software in the office

Before you start
Before you begin your class, ensure that your computer is turned on and the SMART Board 
interactive whiteboard is connected and oriented. 

This hands-on practice assumes you have a basic understanding of the Microsoft Windows 
operating system.

Preparation
  1  Open a blank spreadsheet in Excel software

  2  Type Hotel in cell A2 on your computer’s 
keyboard

  3  Type Flight in cell A3

  4  Type 1000 in cell B3
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Using Ink Aware in the office
Assume you and your colleagues are attending a conference in the near future. As a group, you 
prepared a travel request outlining the anticipated expenses. This request will be presented to the 
accounting department for approval.

  1  One group member states the hotel will cost $150 per night. Press the cell in the spreadsheet 
to highlight the cell in which the cost will be placed. Pick up a pen tool from the SMART Pen 
Tray and write 150 on the interactive whiteboard.

  2  Another group member declares the corporate rate for the hotel is only $115 per night. Put 
the pen tool back in the pen tray and press once on the interactive board to remove 150. 
Write 115. 
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  3  Press the Insert as Text button to add the hotel rate into the highlighted cell. Your text is 
inserted into the spreadsheet and will appear in the pen color used.

  4  Finally, your team lead suggests that you get a minimum of three price quotes for the flight. 
Circle the flight cost in cell B3 and write Get quote. Press the Insert as Image button to insert 
your note as an image into your spreadsheet.

  5  Save your spreadsheet as an Excel software file. Now you can update the travel request with 
your group’s notes and e-mail it to the accounting department for approval.
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Hands-on practice: Using Microsoft PowerPoint 
software on a SMART Board interactive whiteboard

Before you start
Before you begin, ensure that your computer is turned on and the SMART Board interactive 
whiteboard is connected and oriented. 

This hands-on practice assumes you have a basic understanding of the Microsoft Windows 
operating system.

Preparation
Assume your supervisor has requested a brief presentation on the topic of productivity in the office. 
The preliminary work on your presentation requires you to incorporate feedback and suggestions 
from your colleagues. The final presentation will be presented to your supervisor.

Open any PowerPoint software presentation on your SMART Board interactive whiteboard.
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Presenting on an interactive whiteboard
1  Select View > Slide Show to begin your presentation. The Slide Show toolbar automatically 

appears so you can navigate between slides.
2  Press the Next Slide button on the Slide Show toolbar to move forward one slide. Then 

press the Previous Slide button to move back one slide.

3  Advance the slide show by pressing twice on the interactive whiteboard, remembering to 
make the second press to the right of the first

TIP: You can go to the next slide of a PowerPoint software presentation by pressing twice on the 
interactive whiteboard, making the second press to the right of the first. To go to the previous 
slide, make the second press to the left of the first.

Press twice. A second press to the left will move                    
to the previous slide.

Press twice. A second press to the right will move                          
to the next slide.
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4  For emphasis, you want to draw your audience’s attention to the items listed on your 
PowerPoint slide. Pick up a pen tool from the SMART Pen Tray and place a check mark 
beside each point as you discuss it with your colleagues.

5  Use the Slide Show toolbar, or press twice on the interactive whiteboard to advance to the 
next slide
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6  Your colleagues take an interest in the statistics you referenced on your PowerPoint slide 
and ask you to send them the source material. Record their request as a note to remind 
yourself to get back to them later. Pick up a pen tool from the pen tray and write send source 
material. 

7  Return the pen tool to the pen tray

New SMART Notebook file
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8  Since you want to follow up on your note, but you don’t want to save it as a permanent part 
of your presentation, press the Menu button on the Slide Show toolbar and select 
Capture to Notebook from the drop-down menu. SMART Notebook software will open 
automatically and an image of your PowerPoint slide with your written reminder will be 
inserted into a new SMART Notebook file

9  Now that your reminder has been captured to SMART Notebook software, press once on the 
interactive whiteboard to erase your note from your PowerPoint software presentation. 
Advance to the next slide.

10  The next slide in your presentation requires feedback from your colleagues. Pick up a pen 
tool from the pen tray, and record their suggestions. 

11  You are ready to end your presentation. Press the Menu button on the Slide Show toolbar 
and select End Show from the drop-down menu. Select Yes in the SMART Aware message 
box to add your notes to your PowerPoint software presentation.

12  Select File > Save to save your notes into your original presentation, or select 
File > Save As to save to a new PowerPoint software file. Close your presentation.

13  Now select the unsaved SMART Notebook file created earlier in the lesson. Select 
File > Save to save your notes for future reference.
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Basics for SMART 
Notebook™ software
What is SMART Notebook 
col laborat ive learning software?

SMART Notebook™ collaborative learning software is SMART’s interactive whiteboard software. 
Use it in the classroom to create engaging and interactive lesson activities.
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Using SMART Notebook software for the first time
To launch SMART Notebook software, double-click the SMART Notebook icon on 
the desktop. Or, click the Start button in the bottom left of your screen, and select 
Programs > SMART Board Software > SMART Notebook. The Welcome to 
Notebook Software screen will appear. 

When you click New Notebook File, a new file will open. Each new SMART Notebook file contains 
a work area that can be filled with objects. You can add handwritten notes, typed text, graphics, clip 
art and Flash® files to a SMART Notebook file. A key feature of SMART Notebook software is the 
ability to add as many pages as you need to capture or display information.

SMART Notebook 
icon

work area
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SMART Notebook software menu bar
The SMART Notebook software menu bar provides access to many of the same tools and features 
found on the SMART Notebook software toolbar, and some additional tools. Click on the menu item 
you wish to access.

Menu item Functions

File •  Open new or existing files
•  Save a file
•  Save As – save a file for the very first time, save a file with a new name or 

save the file in a new location
•  Save the current page as a Gallery item
•  Import a variety of file formats
•  Export content to a variety of file formats
•  Print files or modify print settings
•  Send a file to a mail recipient as a Notebook file or a PDF
•  Timed Saves – select how often you want your file to be automatically saved 

(it is a good idea to set this to 15 minutes)
•  See a list of recently opened files

Edit •  Undo or redo previous actions
•  Clone, cut, copy, paste or delete selected objects or all objects on the page 
•  Edit a text object
•  Select all unlocked or all locked objects on the page
•  Clear or delete the current page

Menu bar
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View •  Change the current side tab view (Page Sorter, Gallery, Attachments) 
•  Move to the next or previous page
•  Launch the Screen Capture or Screen Shade tool
•  Hide the side scrollbar
•  Customize the toolbar
•  Zoom to magnify or reduce your view of page contents
•  Show All Links
•  Select the language SMART Notebook software displays
•  Set alignment guide defaults

Insert •  Add a blank page, a picture, a graphics file, a Flash file, a Flash video file or 
a Gallery item. Add a link, a sound file or a table.

Format •  Change font styles (bold, underline, italic)
•  Set object properties (color, line width, line style, fill, transparency)
•  Lock object properties and position
•  Infinitely clone a selected object
•  Change the background color of a page
•  Create or set page themes

Draw •  Select, group, ungroup, flip or order objects
•  Access Pen, Creative Pen and Eraser tools
•  Create shapes and lines text
•  Select the fill tool
•  Select a default font face, size and color

Help •  Access the SMART Notebook software Help file
•  Check for software updates
•  Participate in the Customer Experience Program
•  Access information about SMART Notebook software

TIP: You can also access the SMARTNotebook software menu bar drop-down menus by holding 
down Alt or Ctrl and tapping the underlined letter in the menu item (e.g., Edit is Alt + e and Save 
is Ctrl + s).

Menu item Functions
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SMART Notebook software toolbar
The SMART Notebook software toolbar provides access to a number of tools to help you work with 
your Notebook file. By default, the toolbar appears at the top of the SMART Notebook page.

Butto
n

Use this tool to Butto
n

Use this tool to

Display the previous SMART 
Notebook page

Insert a table

Display the next SMART Notebook 
page

Select any object on the page with your 
finger or mouse

Insert a blank SMART Notebook 
page directly after the active page

Write or draw on the SMART Notebook 
page with the pen tool

Open an existing SMART 
Notebook file

Write or draw on the SMART Notebook 
page with the Creative Pen tool

Save your SMART Notebook file Erase digital ink on the SMART 
Notebook page

Paste copied object(s) into a 
SMART Notebook file

Draw a line

Undo the last action you performed Create a shape

Redo the action you performed Draw a shape on the SMART Notebook 
page with the Shape Pen

Delete any selected object Use the Magic Pen to zoom and 
spotlight, or write in disappearing ink

Show/hide the Screen Shade on 
the current SMART Notebook page

Use the current fill effect to fill an object

Open Full Screen view Create a text-entry box for typing

Launch Transparent Background 
Display

Modify properties of a selected object
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By default, the toolbar appears at the top of the SMART Notebook page. If you prefer, it may be 
more convenient to move the toolbar to the bottom of the page. To do this, click the double-ended, 
vertical arrow on the far right of the toolbar.

More toolbar choices
When you click on some toolbar buttons, you are offered more options for creating 
SMART Notebook objects.

Launch Dual Page Display Insert a measurement tool such as a 
ruler, protractor or compass

Launch the Screen Capture toolbar Move the toolbar to the bottom of the 
SMART Notebook page

Activate the SMART Document 
Camera

Pen tool

Line tool

Shape 
tool

Creative pen 
tool

Text tool

Eraser 
tool

Measurement 
tools
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Side tabs
There are four tabs on the SMART Notebook interface, which are shown below on the right-hand 
side of the work area. Click the double-ended arrow to move the tabs from one side of the work area 
to the other. You can hide the side tabs from view when you have finished working with them by 
selecting the Auto-hide check box.

Click the Page Sorter tab to see a thumbnail of each page in the SMART Notebook file, navigate 
to a different page or reorder the pages.

Click the Gallery tab to access collections of SMART’s custom pages, clip art, Flash animations 
and video you can add to the SMART Notebook file. 

Click the Attachments tab to add hyperlinks to or attachments from other software applications to 
the file. 

Click the Properties tab to format shapes, objects and text
.

Move tabs to the 
other side of the 
work area.

Page Sorter tab

Attachments tab

Gallery tab

Properties tab

Auto-hide
check box

Previous page
Next page
Add a page

Undo last action

Increase the
width of the tab

display area.

Page drop-down
menu

Page thumbnail

Page work area
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Page Sorter tab
Click the Page Sorter tab to see thumbnails of all the pages in the SMART 
Notebook file. 

The active page is indicated by a second border around the thumbnail image and 
a drop-down menu. Clicking another page in the Page Sorter tab area makes that 
page active, and its contents are displayed in the work area. To change the page order, drag and 
drop the thumbnail of the page into its new location.

Page Sorter drop-down menu
Clicking the drop-down menu on the active page presents you with eight options.

The second 
border indicates 
the active page.



SMART Notebook software training for SMART Board users level 1 learner workbook

 51

Gallery tab
The Gallery in SMART Notebook software helps you quickly develop and deliver 
lessons in rich graphic detail. Thousands of images, pages, videos, Flash files 
and entire SMART Notebook files are organized into searchable collections that 
will allow you to create attractive, reusable lessons.

. 

Click a collection, and
its content will be

displayed in the lower
Gallery window.

Search by keyword 

Click to view previous
search results
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Finding Gallery content
There are two ways to find content in the Gallery. The search box at the top of the Gallery tab allows 
you to search by keyword – much like using an Internet search engine. You can then browse the 
Gallery collections by selecting a folder.To search for objects in the Gallery using the search field, 
follow these steps:

 1 Click inside the search box

 2 Type a keyword related to the type of object(s) you are looking for

 3 Click the search button to display your results

Select a 
thumbnail and 
drag it to the 
work area.

Click here to import 
content into the My 
Content area of the 
Gallery Collections.

Click the Search 
button to view 
search results in the 
lower Gallery 
window. Click to expand your

search to include the
teacher-contributed

resources in the
SMART Exchange
online community.

The
search

box
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Alternatively, you could browse through individual collections if you were looking for all the objects 
related to a general topic, such as Geography.

TIP: Search singular rather than plural terms for better search results.
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Objects in the Gallery
The lower Gallery window displays the collection of Gallery objects. Gallery objects are organized  
into the following categories: Related Folders, Pictures, Interactive and Multimedia, 
SMART Notebook Files and Pages, and Backgrounds and Themes.

Double-clicking a folder thumbnail in the Related 
Folders area will show all the collections related to 
your search term.

Pictures contains objects such as graphics, and 
photographs. You can drag an object to the work area 
to use as part of a lesson. 

Interactive and Multimedia contains Flash objects, 
video files and objects with sound attached. Objects 
from this folder are used to add rich media content to 
a lesson or presentation. 

Additional files and pages can be found in the 
Notebook Files and Pages section of the Gallery. 
SMART Notebook page thumbnails are identified by 
the folded edge in the top-right corner. 
SMART Notebook files are recognizable by the coil 
binding on the left of their thumbnail images. Dragging 
a page or SMART Notebook file to the work area will 
insert a new Notebook page or series of pages 
directly after the active page. 

Backgrounds and Themes can be used to apply a 
consistent style to pages or groups of pages in a 
SMART Notebook file. Drag a background or theme 
to the work area to change the color and design of the 
page. Backgrounds are recognizable by the folded 
edge in the bottom-right corner and will always be 
inserted behind all the objects already on the 
SMART Notebook page. 
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Identifying Gallery objects
You can identify each type of Gallery object by its appearance within the Gallery collection.I

 Background Picture
SMART Notebook 

Page

 Flash object Audio clip Video clip
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My Content
The My Content area is a Gallery collection reserved specifically for objects you have imported, 
captured or created. It is a good place to store objects that you will use in multiple presentations. 
To add an item to the My Content area, drag an item from the work area to the My Content area.

If you often use a particular page layout, you can store a SMART Notebook page as a thumbnail in 
the My Content area. All the objects associated with the stored page retain their properties. To 
reuse the stored page, drag its thumbnail from the My Content area to the work area.

You can also store an entire SMART 
Notebook file in the My Content area. 
You might do this if you want to give a 
presentation multiple times. To launch a 
SMART Notebook file from the My 
Content area of the Gallery, drag it to 
the work area. 

To import other SMART Notebook files 
from your computer, follow these steps: 

1  Click My Content and click the 
page drop-down menu arrow

2  From the drop-down menu, click 
Add to My Content to launch the 
Add to My Content dialog box

3  Browse to the file you would like 
to add

4  Click the file you would like to add
5  Click the Open button

Your file will appear as a thumbnail in 
the My Content area of the Gallery. 
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Attachments tab
Make your presentations and lessons more cohesive. The Attachments tab 
allows you to link to supporting documents, software and webpages directly from 
your SMART Notebook software file. The Attachments tab is also a good way to 
store documents or websites in your SMART Notebook software presentation 
that you might want to use in your lesson.  

To insert a copy of a file, click the Insert button at the bottom of the Attachments tab, select Insert 
Copy of File, and browse to the file location. Click on the file and click Open. If you drag a copy of 
file attachment to your page, it will become an object with a paper clip icon in the bottom-left corner.

When you have an attachment associated with your presentation, the appearance of the 
Attachments tab changes to remind you that an attachment is there.

A file icon and a hyperlink icon as they 
would appear on the work area
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To enter an Internet address, click Insert Hyperlink, type the Internet address you would like to add 
and a name to display on the SMART Notebook page. Click OK.

There are also occasions where you may want to open a different software application, such as 
Microsoft® Word or Excel® spreadsheet software, while remaining in SMART Notebook software. 
At these times, you will want to insert a shortcut to a file. These files will usually be “executable,” 
that is, they end in .exe.
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The Properties tab
To change the characteristics of an object, click the Properties tab. The properties 
displayed depend upon on the type of object you are working with at the time. The 
following section details what can be altered in each property setting.   

Change Fill Effects
You have many options when you change the fill color of an object. Two are shown below. You can 
fill an object with a pattern or an image. You can also change the transparency of an object.

Remember, to select any object by clicking with your mouse, you must first click the Select 
toolbar button.



Basics for Notebook software

60

Change Text Style
When you click a text object and click the Properties tab, several Text Style options become 
available. You can select the Font, the Size and the Font Style.

Click the drop-down arrow, or click the bold, italics, underline, superscript or subscript buttons.
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Change Line Style
When a line object is selected and the Properties tab is visible, you can change the color, thickness, 
style, starting format and ending format of a line.
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Review questions: Basics for SMART Notebook software
1 What are the four tabs in SMART Notebook software?

2 Describe how to move an object from one SMART Notebook page to another.

3 How do I add a blank page to SMART Notebook software?

 

4 Why would you change the location of the tabs or toolbar located in the SMART Notebook 
software?

5 Why would you use the Attachments tab?
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Review answers: Basics for SMART Notebook software
1 What are the four tabs in SMART Notebook software?

Page Sorter, Gallery, Attachments, Properties

2 Describe how to move an object from one SMART Notebook page to another.

To move an object, drag it from the work area to a thumbnail in the Page Sorter.

3 How do I add a blank page to SMART Notebook software?

Press the plus sign button on the toolbar, or select the drop-down menu on the Page Sorter 
tab, and select Insert Blank Page. 

4 Why would you change the location of the tabs or toolbar located in the SMART Notebook 
software?

Tabs: in the case of team-teaching, or depending on if the user is right or left-handed user
Toolbar: to make it the appropriate height for presenter or participants, or because it offers 
the ability to see top of the workspace which may be otherwise covered

5 Why would you use the Attachments tab?

You might use the Attachments tab to link to files and webpages that you would like to 
reference during a presentation or lesson. If the files or webpages are linked from the 
Attachments tab, your presentation will be more cohesive because you will not need to 
spend time searching for the appropriate file or program on your computer.
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Hands-on practice: Basics for SMART Notebook 
software

Launching SMART Notebook software
1  Launch SMART Notebook by double-clicking the SMART Notebook software icon on the 

desktop
2  If the Welcome to Notebook Software window appears, click on New Notebook File

Editing text
3  Click in the work area, and type your name. Your name appears in Times New Roman font 

face, plain style, 16 pt and black color. 

4  Click the Properties tab and then click your name. On the Properties tab click Text Style. 
Change the font, the size and the font style of your name.
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5  Click Line Style on the Properties tab. Change the color of your name. Click the Save icon 
on the toolbar. Choose a name for your file, and click Save.

6  Double-click the Add Page icon on the toolbar to add two more pages to your file
7  Click the Page Sorter tab.  You will see your two new pages. Page three is now the active 

page, and it is empty. Your name remains on page one. Click the second page.
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Creating a line
8  Click the second page and select the Line icon on the toolbar. Draw a line in the work area. 
9  Click the Properties tab and click the Select icon on the toolbar. Select the line you drew in 

the work area. It is now the active object on the page. 
10  Click Line Style on the Properties tab. Change the color, thickness, style, start shape and 

end shape of your line. Click in the work area. Save your SMART Notebook file.

11  Click the Page Sorter tab and select page three. 
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Creating a shape
12  Click the Shape icon on the toolbar and select the star shape from the subtoolbar. Draw a 

star in the work area on page three. 
13  Click the Select icon on the toolbar. Click the Properties tab and select your star. Your star 

is an active object on the page, and Fill Effects are active on the Properties tab. Change the 
fill color of your star. 

14  Click Line Style on the Properties tab. Change the color, thickness and style of the line 
border of your star. Click in the work area. Save your SMART Notebook file.

Adding Gallery content
15  Click the Select icon on the toolbar and click the Add Page icon to add another page to your 

file. Click the Page Sorter tab. Page four is now the active page.
16  Click the Gallery tab. In the Search window, 

type any search term, and click the Search 
icon, which looks like a magnifying glass. 

Search icon
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17  Click Pictures. Choose one of the pictures, and drag it to the work area. Your picture is now 
an active object.

18  Click the Properties tab, and change the transparency of the picture. Save your file.
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19  Click the Page Sorter tab. Drag page four so it will appear immediately after page one. Save        
your file.            

NOTE: When you drag a page to a new location, a solid bar indicates the new position.

20  Share your results with your colleagues. Close SMART Notebook software by clicking 
File > Exit.
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Objects in SMART 
Notebook software
What is an object?

All text, images, audio, video and multimedia are considered objects in SMART Notebook software. 
You can change the properties of these objects to make your presentation more effective.
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Manipulating objects in SMART Notebook software
Anything placed inside the work area is considered an object. You can add an object to a SMART 
Notebook page using any of the following methods:

•  Typing text 
•  Drawing or writing in the work area with a pen tool
•  Creating a geometric shape with the SMART Notebook software toolbar drawing tools
•  Inserting content from the Gallery, a computer, or the Internet

Modifying objects
Select any object on the SMART Notebook page to change its properties. Selected objects have 
two handles. Use the solid handle to rotate the object and the clear handle to make it larger or 
smaller.

Drag to rotate
the object

Drag to rotate the object

Drag to resize the 
object

Click for the drop-down menu

Drag to resize the object
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Moving objects
To move an object from one page to another, ensure the Page Sorter tab is active and the 
Auto-hide check box is not checked. Then click the object you would like to move and drag it to the 
appropriate page.

You can also move objects using the Cut and Paste commands from the drop-down menu and the 
menu bar. Click the object to select it. From the object drop-down menu, click Copy if you want to 
keep the original object, or Cut if you want to remove the original object. Click the page on which 
you want the object to appear. From the drop-down Edit menu on the menu bar, click Paste.

Drag from the active page (page one) to page three.
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The Alignment Guides
The Alignment Guides allow you to control the placement of objects on your page, so objects can 
be placed exactly where you want them to be. Click View > Alignment from the menu bar to set 
the alignment guide defaults.

Lines mark the center of your page

Click the Guide color box to change the color of the guide lines.
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Object drop-down menu
The object drop-down menu gives you one-click access to an object’s properties.

Item Description

Clone Creates an exact copy of the object or objects next to the original object

Cut Removes the selected object from the SMART Notebook page and places it 
on the clipboard

Copy Creates an identical copy of the selected object

Paste Places the object from the clipboard onto the SMART Notebook page

Delete Deletes the selected object

Check 
Spelling

Checks the spelling for the text object(s) selected

Locking Protects an object or an entire group of objects from editing. Choose between 
Lock In Place, Allow Move, and Allow Move and Rotate.

Grouping Group two or more objects to act as one object. Select, change, move, delete 
and resize a group as a single unit. To edit or resize the objects individually, 
ungroup them.

Flip Flip an object either horizontally or vertically

Order Change the order in which objects are layered

Infinite Cloner Make unlimited copies of an object on a SMART Notebook page. Select and 
drag the object to create as many clones as required.

Link Link an object to a website, another SMART Notebook page, a file on a com-
puter or a file, such as a video clip or other multimedia element, residing in the 
Attachments tab

Sound Attach a sound file to any object

Properties Change the visual characteristics of any object you’ve created in SMART 
Notebook software
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Locking objects
Locking an object allows you to protect the properties you have applied to it. The choices in the 
Locking submenu allow you to determine the type of lock to use on an object.

Object drop-down menu
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Click the Lock In Place option to ensure the object cannot be altered or moved in any way.

Click Allow Move to let you move an object, but not 
resize, rotate or change any of the object’s properties. 
You might use Allow Move if you were creating a SMART 
Notebook file that would be used to teach ordering, but 
wanted to ensure all the objects on the page remain the 
same size. 

Click Allow Move and Rotate to let you move and rotate 
an object, but not resize it. You might use Allow Move 
and Rotate if you created a SMART Notebook file with a 
puzzle component and you wanted your students to 
arrange the puzzle pieces. You can place the puzzle 
pieces wherever you wish on the SMART Notebook page 
and rotate them to make the puzzle more challenging – 
without worrying that participants might resize the piece. 

Unlock an object by doing the following:

  1  From the menu bar, click Edit > Select All Locked Notes. The Lock icon will appear on any 
objects you have locked.

  2  Click the Lock icon
  3  Click Unlock from the menu. Alternatively, right-click an object – the Lock icon will appear 

with its lock menu. Click Unlock from the menu.

Lock icon
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Grouping objects
Select two or more objects by holding down your left mouse button and dragging your mouse 
diagonally so the objects are surrounded by a selection box. You can also hold the Shift key down 
while you click each of the objects you wish to group. 

Click the drop-down menu from any of the objects and choose Grouping > Group.

If you want to separate the objects, select the grouped objects again and choose Grouping > 
Ungroup. The Ungroup function will also break handwritten notes into individual pen strokes.
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Infinite Cloner
The Infinite Cloner option in the object drop-down menu allows you to reproduce an object an 
unlimited number of times, without having to click Clone repeatedly from the drop-down menu. You 
might use the Infinite Cloner to teach counting or to present math problems. 

Click Infinite Cloner from an object’s drop-down menu. Now, when you click and drag an object 
set to infinitely clone, another identical object is created. You can continue to create clones of the 
object by dragging it until you deselect Infinite Cloner.

To turn off the Infinite Cloner property, right-click the object, and click the Infinite Cloner box. The 
check mark will disappear, indicating the Infinite Cloner is off.

Select, then press and drag an object to create
an identical object.

Infinity symbol
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Flip objects
Click Flip from an object’s drop-down menu to flip an object either horizontally or vertically. 

Order objects
You can change the order in which objects are layered by selecting Order from the drop-down 
menu.

To bring an object directly to the top layer of the page, use the Bring to Front command. 

To send an object to the bottom layer of the page, use the Send to Back command.

To reorder an object one layer at a time, use the Bring Forward command or the Send Backward 
command. 

Left/Right

Original

Up/Down

Four objects ordered in different ways
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Adding links to objects
You can link an object to a website, another SMART Notebook page, a file on your computer or a 
file residing in the Attachments tab. Click Link from an object’s drop-down menu, and choose the 
type of link you would like to add to your object from the Insert Link dialog box.

You can choose to launch your link by clicking an icon at the side of the object or by clicking on the 
object itself.

Link to a Web Page

Once the link is attached to the object, every time you click it your Internet browser will launch and 
display the requested page.
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Link to a Page in this File
You might use this type of link when presenting a question. For example you could ask a question, 
then ask a student to select from a set of objects representing potential answers.

The object containing the correct answer could link to a reward screen. The objects containing 
incorrect answers could link to a page that encourages the student to try again.

Link to a File on this Computer
Link to a file stored on your computer that relates to your lesson or presentation. For example, you 
could link to a Microsoft® Word or Excel® software file that contains information that qualifies a 
statement in your SMART Notebook file.
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Link to Current Attachments
Link to a file you have stored in the Attachments tab.
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Handwriting recognition
If you have written something with a pen tool in SMART Notebook software, you have the option of 
having your handwriting recognized and converted to text. This tool is primarily used when working 
on the interactive whiteboard, but does have teaching applications when developing lessons on the 
computer.

To convert a handwritten word to text, click the object drop-down menu and choose your word from 
the list.

TIP: You can recognize words in different languages. Just select a different default language from 
the list.
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Shape recognition
Shape recognition works in a fashion similar to handwriting recognition. Shapes can also be 
recognized as letters and numbers.

If you draw a shape with a pen tool, you can go to the drop-down menu when the shape 
is selected and then select Recognize Shape to convert it to a shape. You can also 
use the Shape Pen from the SMART Notebook software toolbar to draw instant shapes. 
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Typed text
To add typed text as an object to the SMART Notebook file, simply type with a keyboard and press 
Enter when you have finished.

The Fonts toolbar appears while you are typing or after you click the text object icon on the SMART 
Notebook software toolbar and click on the work area. Use it to format properties, such as font, size, 
font style, color, alignment, rotation, bulleted list, subscript, superscript, mathematical symbols and 
spell checker options. You can also quickly change your font by clicking on one of the options in the 
text object submenu.

Text object icon

Text object submenu

Font face

Font size Font style
Font color

Alignment

Bulleted list
Math symbols

Subscript or superscript

Rotation

Mathematical symbols

Check spelling
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Check Spelling
Click Check Spelling from the drop-down menu to check the spelling of a text object. 

The Spelling Check dialog box will appear with a list of spelling suggestions if the spelling of the 
selected text object is incorrect. Chose the correct spelling of the text object from the suggestions 
list, and click the Change button to correct the misspelled word.

When Check Spelling is turned on at the toolbar, make sure you tap the space bar at the end of the 
word. This action indicates you are finished typing, and Check Spelling can begin.
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When you turn the spell checker on, incorrectly spelled words will appear underlined in red as you 
type.

To spell check all the text objects in your file, click on any one text object to select it, and from the 
drop-down menu click Check Spelling .... SMART Notebook software will check the spelling of that 
word and then ask if you wish to check the rest of the document. You are notified when spell check 
is complete.

Check Spelling is on

Check Spelling is off
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Drawing tools
Use the drawing tools – accessible from the SMART 
Notebook software toolbar – to create your own objects. 

Pen and Eraser tools
Use your mouse or finger to create objects with the Pen, Creative Pen or Shape Pen tools.

 

The Eraser tool erases anything you have created with a pen tool. When you erase part of an object, 
the properties of the remaining parts can be changed independently.

The same object drawn 
with three different 
pens: Pen, Creative 
Pen, Shape Pen Part of the 

Creative tool 
object erased by 
the Eraser tool
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Line tool
Press the Line button on the SMART Notebook software toolbar to draw straight lines. Select any 
line made with the Line tool, and drag the end points to stretch it or change the angle. Hold down 
the Shift key while pivoting a line, and the line will snap in place every 45°. 

Shapes tool
Enhance any activity with the Shapes tool on the SMART Notebook software toolbar. 

Create a shape

When you click on the Shapes icon, a menu of shapes will appear. Click on the shape you would 
like to use, and position your cursor on the page where you would like to create the shape. Hold 
down the left mouse button and drag your cursor until your shape is the desired size. To draw a 
perfect shape, hold down the Shift key while drawing your shape.

Once a shape is on your SMART Notebook page, it can be modified 
the same way you modify other objects, using the rotation handle, the 
resize handle or the drop-down menu. 

If you click on the Select tool icon and then double-click on the shape, 
a text box will appear and you can add a label to your shape.

Fill tool
Any shape can be quickly filled with color by tipping the paint can over the shape object. 
The fill color is the last color chosen from the color palette. To change the color in the paint 
can, click on the shape icon, click on the paint can, click on the Properties tab and select a 
color from the color palette.

Drag
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Measurement tools
You can use measurement tools to record, measure, and check the dimensions and other aspects 
of objects on a SMART Notebook page. The measurement tools include a ruler, protractor, 
Geodreieck protractor, and a compass. 

To use a measurement tool, press the Measurement Tools  button on the SMART Notebook 
software toolbar, and then select any of the measurement tools from the submenu. 

You can manipulate the ruler, 
protractor, and Geodreieck 
protractor to fit the task at hand. 
You can spin, shrink, or expand 
any of the measuring tools. You 
can also extend the ruler to 
accommodate longer 
measurements without 
changing its scale. You can 
manipulate the measurement 
tools by pressing and dragging 
on different parts of the tool. 

You can extend or shorten the arms of the compass to create the desired angle, and you can spin 
the compass by holding the green rotate handle. To draw a line using the compass, press and drag 
on the colored part of the compass. The compass line style is the same as the Pen tool, and you 
can modify the line style in the Properties tab.
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Inserting images into SMART Notebook software
To add an image to the SMART Notebook file, use the Insert menu to import graphics or clip art 
from another location on your computer. 

Capturing information
The Screen Capture toolbar allows you to capture an image, such as a digital photo from the 
Internet, to a SMART Notebook page. To access the Screen Capture toolbar, click the Screen 
Capture button (the camera), on the SMART Notebook software toolbar. Always remember to 
respect copyright.

Button How it’s used

Hold down the left mouse button, and drag to outline the rectangular area you want 
to capture. Release the left mouse button after the area is selected.

Click in the window you want to capture. Release the left mouse button after the 
desired window appears as a hatched area.

Navigate to the screen you want to capture, and click the button to capture the 
entire screen

Press and drag to create a freehand shape around the area you want to capture. 
Release the left mouse button after the area is selected.
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Review questions: Objects in SMART Notebook software
1  Label the rotation handle, the resize handle and the drop-down menu on the object below.

2  Describe how to move an object from one SMART Notebook page to another.

3  Why would you add a link to an object that would direct you to another page in your 
SMART Notebook file?
 

4  What is the difference between Send to Back and Send Backward when ordering 
objects?

5  How do you spell check within a SMART Notebook file?
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Review answers: Objects in SMART Notebook software
1  Label the rotation handle, the resize handle and the drop-down menu on the object below.

2  Describe how to move an object from one SMART Notebook page to another.

To move an object, drag it from the work area to a thumbnail in the Page Sorter.

3  Why would you add a link to an object that would direct you to another page in your 
SMART Notebook file?
You might use this type of link when presenting a question in SMART Notebook software. 
For example, you could ask a question, then ask a student to select one of the answers. The 
object containing the correct answer could link to a reward screen. The objects containing 
an incorrect answer could link to a screen with an object that encourages the student to try 
again. 

4  What is the difference between Send to Back and Send Backward when ordering 
objects?
Send Backwards reorders objects one layer at a time. Send to Back sends an object to 
the very bottom of a pile of objects.

5  How do you spell check within a SMART Notebook file?
On the fonts toolbar, select the Check Spelling icon. From the Object drop-down menu, 
select Check Spelling.

Rotation handle

Drop-down menu

Resize handle
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Hands-on practice: Objects in SMART Notebook 
software

  1  Launch SMART Notebook software by double-clicking on the SMART Notebook software icon 
on the desktop. Open a new file.

  2  Set your Alignment Guides (View > Alignment). Click all options to activate them. Click OK. 
The thin lines appear that mark the horizontal and vertical centers of the page. Page one is 
the active page. Save your file.

  3  Create a text box that contains your name. From the drop-down menu, click on Infinite 
Cloner. From the original text box, drag five copies of your name to various locations on the 
page. Turn off the Infinite Cloner by right-clicking on the original, and clicking on the Infinite 
Cloner box to deselect it.

  4  Align three of your names by dragging them.                                                                               
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NOTE: With the alignment guides on, grids appear to help you align the objects vertically and 
horizontally. 

  5  Hold down the left mouse button, and drag to select all three names. Click on one of the drop-
down menus, and click Grouping > Group. The three objects are now one. 
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  6  Click on the drop-down menu, and select Locking > Lock In Place. The object is now locked 
and cannot be moved. If you want to unlock the object, from the Menu bar click Edit > Select 
All Locked Notes. Then click the locked icon and click Unlock. Save your file. 

Lock icon
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  7  Click the Add Page icon to add another page. You are now on the newly created blank page 
two. Find a graphic from the Gallery, and drag it to your page. Make the graphic larger by 
dragging on the clear circle. Rotate the graphic by dragging on the solid circle. Save your file.

  8  Click on the graphic and from the drop-down menu, click Copy. Add a page. From the menu 
bar, click on Edit > Paste. Click on the graphic, and from the drop-down menu click Flip > 
Up/Down. Save your file.

  9  Add another page. Click the Text Box icon, and add four text boxes containing the words 
hellp, bekaus, recieve, and elefant. Click the Select icon, and click one of the words. From 
the drop-down menu, click Check Spelling. Correct the spelling of your four words. Save 
your file.
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  10  Click the Add Page icon to add another page. You are now on the newly created page five. 
Click the Text Box icon, turn on the spell checker by clicking the icon. Add four text boxes 
containing the words hellp, bekaus, recieve and elefant. To have the spelling checked 
automatically, you must tap the space bar at the end of the word to signify the word is 
complete. If you do not know the correct spelling, you can right-click on the word for 
suggestions. Save your file.

  11  Click the Add Page icon to add another page. You are now on the newly created page six. 
Click the Create Shape icon, and draw four shapes of different sizes. Remember, if you 
want to draw perfect circles, hold the Shift key down while you are drawing. Click the 
Properties tab. Fill each circle with a different color. Practice ordering your objects by moving 
them so they overlap and then bringing objects to the front or sending objects to the back. 
Save your file.

  12  Share your results with your colleagues. Close SMART Notebook softwareby clicking File > 
Exit.
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Creating interactive 
lesson activities
Where do I  start  when creat ing a 
lesson act iv i ty for  the 
SMART Board interact ive 
whiteboard?

SMART Notebook software tools include functions that help you use the interactive whiteboard 
more effectively and allow you to create engaging, interactive and dynamic classroom lesson 
activities.
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Creating interactive lesson activities
This section is intended to act as a reference for the best practices for creating and 
presenting lesson activities using SMART Notebook software.

You are already familiar with the basics of SMART Notebook software, such as how to 
write in the work area, how to add new pages to your SMART Notebook file, how to navigate from 
one page to another and how to select and move objects on a SMART Notebook page. 

Review of design basics
Lesson activities need to be designed for both content and presentation. The SMART Board 
interactive whiteboard is a visual and an interactive medium. Knowing a little about design and the 
best practices on how to integrate interactivity using SMART Notebook software will help you create 
lesson activities that meet curriculum learning objectives and engage students. Creating content in 
SMART Notebook software with the knowledge that it will need to be presented in a classroom 
setting will ensure your lesson goes smoothly. 

Once you have determined what content you will be teaching, create a title page and write your 
teacher’s notes at the beginning of your lesson activity. Title pages and teacher’s notes focus 
learning objectives and provide important information to any other teachers who use the lesson 
activity. You can see examples of how other teachers have created these items by downloading 
any lesson activity from the SMART Exchange online community http://exchange.smarttech.com.

Content Presentation
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Setting up your page
Once you have an idea for a SMART Notebook software lesson activity, you will need to start 
designing your page. One of the first things you will want to do is decide on a background color. 

When choosing a color, keep in mind that very bright or intense colors can be distracting and draw 
attention from the page content to the background. A bright yellow might seem like a fun choice, but 
it may also distract from other elements on your page. Reserve the most vibrant colors for individual 
objects on your SMART Notebook page to which you want to draw student attention.

Select a background color by selecting Format > Background from the SMART Notebook software 
menu. A color palette will launch from which you can choose the background color of your SMART 
Notebook page. 
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Working with fonts in SMART Notebook software
Next, you should choose the fonts you will want to use for the remainder of your lesson activity. One 
way to set your font is to select your text and use the functions available from the Fonts toolbar. The 
Fonts toolbar appears whenever you are typing on the SMART Notebook page or after you double-
press a text object. 

Use only one font throughout your lesson activity. Too many fonts can be distracting to the eye and 
draw attention away from important points. 

General guidelines for choosing fonts for your SMART Notebook software lesson activity include 
the following:

•  Titles should be at least 28 point and a bold type face
•  Text used for sentences and paragraphs should be at least 22 point and in a regular type 

face
•  Make sure the font color you choose is easy to read and see against the background color 

you have chosen
 

Font face

Font size

Font style

Font color

Alignment, rotate, bullets, subscript,              
superscript and special characters

Spell check
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Math and science symbols
Math and science teachers will find the math and science symbols particularly useful for writing 
equations or formulas. When you click on the Math and Science icon, a series of submenus are 
revealed. Clicking on each submenu reveals another series of choices. Click on your choice to 
insert that symbol into your text box.

Click on the Math and science symbols icon to reveal the math and science submenu
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Adding interactivity
One of the benefits of SMART Notebook software is the ability to modify objects on the page. This 
section will focus on some of the different ways you can engage your students by designing 
interactive lesson plans. 

Reveal
One of the quickest ways to add interactivity to a lesson activity is to hide the answer to a question 
behind an object on the SMART Notebook page. The following information will provide four different 
methods that you can use to create reveal activities that can easily be integrated into any 
curriculum. 

Move and reveal
One way to create a reveal activity is to hide an answer behind another object. 

  1  Type your question and answer
  2  Draw a rectangle, and fill it with color to hide the answer
  3  Double-click the shape for the ability to add text to it – ensure your text is a different color 

from the rectangle
  4  Type Move the box to reveal the answer – you are adding instructions to the shape so 

students, other faculty members or a substitute teacher will be able to work with the file. 
Without the instructions, others might assume they are supposed to write the answer over the 
shape instead of moving it to reveal the answer.

  5  Move the shape to reveal the answer

TIP: It is a good practice to select Order > Bring to Front from the drop-down menu on any object 
you will be using to cover an answer. This action will ensure your students don’t see the answer 
before it is time for it to be revealed.

What is the national animal of England? What is the national animal of England?

The lion

Move the 
box to 

reveal the 
answer.

Move the 
box to 

reveal the 
answer.

Before After
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Erase and reveal
Another way to reveal information is with the Eraser tool.

  1  Type your question and answer. Use a pen to cover 
the answer with digital ink.

  2  Click on a pen tool. Choose an ink color the same color as the page background. For 
example, if the page background is white, then the digital ink should also be white.

  3  Click on the Eraser tool, and erase the digital ink covering the answer. The Eraser tool will 
only erase objects created with digital ink. Anything typed with your keyboard cannot be 
erased with the Eraser tool.

 

TIP: Add instructions to let the class or other teachers know that all they need to do is use 
the eraser.

Before After
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Order and reveal
Another way to reveal information is by ordering objects.

  1  Create an object
  2  Create a second, larger solid object
  3  Move the larger object over the smaller object, which will be hidden
  4  When it is time to reveal the smaller object, you can either move the larger object aside or 

change the order of the larger object to Send to Back

TIP: Add instructions to let the class or other teachers know that all they need to do is move 
the object.

Yellow circle Sent to BackYellow circle covering red eight
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Screen Shade and reveal
A fourth way you can reveal information is with the Screen Shade tool. 

  1  Type your question and answer
  2  Click the Screen Shade button on the SMART Notebook software toolbar
  3  Drag the Screen Shade so only the answer to your question is covered
  4  When you are ready, drag the Screen Shade so it no longer covers the answer. This action is 

similar to using paper to cover answers that would be displayed through an overhead 
projector.

TIP: When you open a SMART Notebook file, the Screen Shade will be covering the same area 
it was hiding, and you will be able to start discussing the content in your file from exactly where 
you left off.

Before After
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Identify and label
Drag and drop activities are an excellent way to determine if your class has achieved recognition 
about specific learning objectives.

To create a drag and drop labeling activity, add the object you want labeled to the work area. The 
object can come from the SMART Notebook software Gallery or it might be a graphic you imported 
using the Insert menu. Use the object drop-down menu to lock in place the object that will be 
labeled. This action ensures the object won’t be accidentally moved during the lesson activity. 

Next, make the labels for your diagram and line them up at the bottom of the SMART Notebook 
page. Then you can ask members of the class to drag the labels to the appropriate area of the 
graphic. 

You may want to add a link to an object, such as the diagram of the digestive system above, to 
another SMART Notebook page with an answer key. This page will help anyone you share the file 
with find the correct answers. 
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Drag and drop activities can also be used for text-based lessons. For example, you might drag 
events to specific dates on a timeline, define a series of words or match information.

Infinite Cloner
The Infinite Cloner allows you to reproduce an object an 
unlimited number of times, without having to select Clone 
repeatedly from the drop-down menu. The Infinite Cloner also 
helps keep your SMART Notebook file’s size smaller than if you 
were to copy and paste the same information, making the file 
easier to share with your colleagues.    

To set an object as an Infinite Cloner, complete the following 
steps:

  1  Click an object
  2  Click the object drop-down menu
  3  Click Infinite Cloner
  4  Click the object, then drag to create an identical object

Press and drag to create 
an identical object
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Using the same object for multiple answers
One advantage of the Infinite Cloner feature is the ability to create a drag and drop activity without 
diluting the pool of available options each time a question is answered correctly 

Set each number on the number 
line as an Infinite Cloner.

Use the same number multiple 
times to answer the questions.

Young students “fill in the 
blanks” with infinitely cloned 
notes, or on blank music 
sheets, compose songs for 
their classmates to play.
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Keeping information in context

Another benefit of the Infinite Cloner feature is that it makes it easy to keep information in context. 
This feature is especially useful for text-based lessons.

Set each letter of a word as an 
Infinite Cloner. Drag the letter to a 
different area of your page to 
create anagrams. The original 
word will remain in place. 

You may want to set a timer to 
make the lesson more 
challenging. An interactive timer is 
available from the Gallery 
Collections. 
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Magic Pen
The Magic Pen icon from the SMART Notebook software toolbar allows you to highlight 
parts of your SMART Notebook page in a way similar to the Spotlight tool on the SMART 
Board interactive whiteboard.

Magic Pen Spotlight
Click on the Magic Pen icon on the SMART Notebook toolbar to activate it. Draw a circular shape 
on the part of the work area you wish to highlight. When you move your cursor over the magic 
shape, it turns into a double-ended arrow. This arrow allows you to make the highlighted area larger 
or smaller.

Mona Lisa
Leonardo da Vinci
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Magic Pen magnify
When you use the Magic Pen and draw a rectangle around an area on your SMART Notebook 
page, it will allow you to zoom into that area.

When your cursor approaches the magic shape, it turns into a hand. This hand allows you to move 
the magic shape to zoom or highlight a different selection. The double-ended arrow allows you to 
resize the zoom or highlight area.

To close a magic shape and return your work area to normal, click on the X in the box.

When you write or draw with the Magic Pen, the ink disappears in about 10 seconds. This feature 
is an excellent way to keep your work area uncluttered. It is also a fine way to offer sequential 
problem solving clues to a class working on a SMART Board activity. You can use the Magic Pen 
to warm up the class by playing timed Brain Gym type exercises.

When the Spotlight or the Magic Pen are active, teachers can only write on or activate components 
in the spotlighted area.
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Sharing your SMART Notebook file
Extend your students’ learning by distributing SMART Notebook 
lessons as a reference for homework and studying. 

Students or colleagues who don’t have SMART Notebook 
software installed on their computers can open your files using the 
SMART Notebook Express™ web application. This lightweight 
version of SMART Notebook software is accessible online 
anytime at no charge. You don’t need to log in and there’s no 
software to download - all you need is Internet access. 

SMART Notebook Express is available at http://express.smarttech.com. 

You can also share your SMART Notebook file by selecting File > Export. You can save your file 
as a webpage, series of image files, PDF or Microsoft PowerPoint presentation. 
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Review questions: Designing interactive lesson activities
  1  What are some ways you can reveal answers to the group?

  2  How would you use the Magic Pen?

  3  How do you access the additional math and science symbols?

  4  How would you use the Infinite Cloner?

  5  Why is font selection important in creating a SMART Notebook file?
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Review answers: Designing interactive lesson activities
  1  What are some ways you can reveal answers to the group?

Move and reveal
Erase and reveal
Order and reveal
Screen Shade and reveal

  2  Why would you use the Magic Pen?

Bring attention to one area in SMART Notebook software

  3  How do you access the additional math and science symbols?

Double-click typed text and select the math and science symbols icon 

  4  How would you use the Infinite Cloner?

To reproduce an object an unlimited number of times, for instance, in counting activities, 
graphing exercises, spelling and word games

  5  Why is font selection important in creating a SMART Notebook file?

Allows for clarity; keeps the file consistent; allows for everyone in the room to see the text
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Hands-on practice: Designing interactive lesson 
activities

Preparing your lesson
You will prepare a geography lesson activity that asks students to match North American countries 
to their flags. You can use the concepts outlined in this hands-on practice to prepare and deliver 
lessons in other subject areas.

  1  Open a blank SMART Notebook file

  2  Click the Gallery tab to search or browse collections of SMART’s custom pages, clip art, 
Flash® animations and video files. For this example, you search for flags of North America.

  3  Type the keyword flags 

  4  Click the Search icon, which is 
the large magnifying glass, to 
initiate your search.

  5  SMART Notebook software 
displays your search result(s) 
as a thumbnail image matching 
your search criteria. In this 
example, a folder named Flags 
will appear.

  6  Double-click the folder 
thumbnail to view its contents

  7  Scroll through the Gallery 
collection to find flags for the 
United States, Mexico and 
Canada. Drag each flag to the 
work area.

TIP: Deselect the Auto-hide check box to keep the Side Tab visible. This action will provide you 
with easy access to the Page Sorter and Gallery tabs as you prepare and deliver your lesson.

Double-click 
the folder 
thumbnail to 
view its 
contents.

Click to initiate 
search
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  8  Resize each flag by diagonally dragging the resize handle. Ensure the flags are 
approximately the same size. 

  9  Align the flags horizontally

10  Write the name of each country in a different color

11  Click United States, for example, and choose the appropriate typed text from the object’s 
drop-down menu. Convert Mexico and Canada from handwritten to typed text also. 

12  Click Clone from the object’s drop-down menu to make a copy of the name of each country. 
There should be two country names for each flag. 

Drag an object’s 
resize handle to 
change its 
dimensions.
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13  Organize the names of each country so that one set of country names is placed in a vertical 
line on your work area. Drag the other country names over their corresponding flags. 

14  Click the United States flag, for example, and choose Order > Bring to Front from the 
object’s   drop-down menu to cover the name United States. Complete this task for the 
Mexican and Canadian flags. 

15  Click File > Save to save your SMART Notebook file. Give your SMART Notebook file a 
name, and choose the location where you want to save it. 

The United States flag is positioned behind the typed text. The United States flag is now 
positioned in front of the text.
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Using your lesson in the classroom
After opening your saved SMART Notebook file on the SMART Board interactive whiteboard, ask 
your students to drag the name of each country underneath its corresponding flag. Once the 
exercise is completed, remove the flags to reveal the correct answers. 

You can add as many pages to your SMART Notebook file as you need to create additional lesson 
activities, such as labeling continents or identifying capital cities on regional maps.

Preparing your lesson: Advanced features
The My Content area is a Gallery collection reserved specifically for objects and lessons you have 
imported, captured or created, such as the lesson you just finished preparing. It’s also a good place 
to store objects and lessons you use frequently or want to share with your colleagues.

  1  Open your geography lesson

  2  Click on the Gallery tab. By default, the My Content folder is selected.

  3  Click the My Content drop-down menu and choose New Folder 

TIP: Select a fun setting from the Creative pen menu to add check marks to correct answers.
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  4  Launch the On-Screen Keyboard and type Country Lesson. You have now created an area 
where you can store all objects related to your geography lesson. 

  5  Drag each flag and country name into your new Gallery collection. Your new Gallery 
collection now contains nine individual Gallery items – one flag and two names for each 
country.

Create a new folder. Your new folder called Country Lesson appears 
My Content.
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  6  Select the Page Sorter tab. Insert a blank SMART Notebook page by clicking the 
Add Blank Page icon on the SMART Notebook software toolbar. 

  7  From the Shapes drop-down menu on the SMART Notebook software toolbar, 
select the square. Position your cursor on the left side of your work area and draw a 
large rectangle. 

Click the Select tool from the SMART Notebook software toolbar. Fill the rectangle with color by 
selecting the rectangle, then choosing Properties from the object’s drop-down menu.

  8  To the right of the rectangle, write or type Languages: and below this write or type English, 
Spanish, English and French

TIP: Alternately, you could change the rectangle’s properties by using the Properties tab.
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  9  Press the page thumbnail’s drop-down menu in the Page Sorter tab. Select Add Page to 
Gallery to place the entire SMART Notebook page into the My Content area of the Gallery 
Collections. This action gives you quick and easy access to SMART Notebook pages for 
lesson planning and delivery.   

  10  Drag the Mexican flag from the My Content area to the top-left corner of the rectangle you 
created in step seven. Then drag the word Mexico to sit directly below the flag. 

TIP: Name your new SMART Notebook page Language Exercise so you can organize your 
Gallery items into meaningful groups.
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11  Drag the Language Exercise page you created in step 10 to the work area of your SMART 
Notebook file. This action will automatically insert a new SMART Notebook page directly after 
the active SMART Notebook page.

12  Repeat steps 11 and 12 using the Canadian and United States flags and associated text 

13  Press File > Save to save your SMART Notebook file

Using your lesson in the classroom
Invite your students up to the SMART Board interactive whiteboard to draw an arrow from the 
language text to the corresponding flag using the Line tool or a pen tool from the pen tray. You can 
hide the correct answers behind the rectangle or flags. 

TIP: Share your geography lesson with other colleagues using the SMART Board interactive 
whiteboard in the classroom. Select Export as Collection File from the My Content drop-down 
menu to distribute your electronic file.
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Additional resources
What’s next?

Many resources are available to help you take the use of your SMART hardware and software to 
the next level, including free training materials on the SMART website and a special online 
community for educators.
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SMART training and professional development 
SMART’s training and professional development website hosts additional training resources and 
support, including free learning resources, online training sessions and self-paced courses to help 
you effectively use any SMART product. 
Visit http://smarttech.com/us/Resources/Training.

Free learning resources
SMART provides many learning resources free of charge to help you continue your professional 
development and explore new products.

Click Browse all training offerings on SMART’s training and professional development website 
to find a complete selection of product training, including free learning resources. 

Live online training sessions
SMART online training sessions are 30- to 90-minute computer and telephone conferences that 
offer a quick overview of the basics of SMART products. Each session is led by a SMART trainer 
who uses SMART products every day. SMART’s online training sessions are useful as a review and 
they give you an opportunity to ask questions.

Live online sessions support a variety of products, including the following:

•  SMART Board interactive whiteboard

•  SMART Notebook software

•  SMART Classroom Suite

•  SMART Response interactive response system

We are always developing new, live online training offerings. Visit SMART’s training center often to 
learn about the latest sessions. 

Self-paced courses
Access self-paced courses through the SMART Learning Center on a variety of product-specific 
topics such as SMART Notebook and SMART Notebook SE, SMART Response and SMART Sync. 

Visit http://smarttech.com/us/Resources/Training/SMART+Learning+Center
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SMART’s support site
SMART’s support site offers a variety of product support options. Visit SMART’s support site to 
download software, find installation and user's guides, “how-to” and troubleshooting articles, 
solutions for your SMART product and answers to your questions. You can also use SMART’s 
support site to contact technical support and to register your SMART product.

Visit http://smarttech.com/us/Support/Browse+Support.

The SMART Exchange website
The SMART Exchange website is an online community where educators can share resources and 
ideas with other educators worldwide. It is where you’ll find the following resources:

•  Free learning resources for use with SMART products, including content collections, software 
applications and website resources

•  Hundreds of SMART Notebook software lesson activities correlated to state and provincial 
curriculum standards

•  Professional development programs to reward, recognize and support educators

•  Advice for educators about using SMART products, integrating peripherals, mastering grant 
writing and evaluating technology

Visit www.exchange.smarttech.com for more information.







Contact SMART Technologies
Toll Free 1.888.42.SMART (U.S./Canada)

or +1.403.245.0333
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